automake build does not work on OSX

mkdir build
cd build
../configure

checking for uid_t in sys/types.h… yes

checking whether the compiler recognizes bool as a built-in type… yes

checking for ld used by gcc… /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld

checking if the linker (/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld) is GNU ld… no

checking for shared library run path origin… done

checking how to run the C++ preprocessor… /lib/cpp

configure: error: in `/Users/clausklein/Downloads/agentpp/agent+±4.5.0/build’:

configure: error: C++ preprocessor “/lib/cpp” fails sanity check

See `config.log’ for more details

Ok, and what is the content of config.log then?
(I have no problems to build SNMP++ and AGENT++ with cmake or autoconf tools on MacOS BigSur. So I do not think it is a general problem. Therefore the above mentioned config.log would be interesting :slight_smile:

configure:9161: /lib/cpp -D_XOPEN_SOURCE=XPG4.2 conftest.cpp
…/configure: line 2219: /lib/cpp: No such file or directory
configure:9161: $? = 127
configure: failed program was:
| /* confdefs.h /
| #define PACKAGE_NAME “agent++”
| #define PACKAGE_TARNAME “agent++”
| #define PACKAGE_VERSION “4.5.0”
| #define PACKAGE_STRING “agent++ 4.5.0”
| #define PACKAGE_BUGREPORT “support@agentpp.com
| #define PACKAGE_URL “”
| #define PACKAGE “agent++”
| #define VERSION “4.5.0”
| #define OS_TYPE “darwin20.3.0”
| #define HAVE_NAMESPACES //
| #define HAVE_NAMESPACE_STD /
/
| #define HAVE_STL //
| #define HAVE_STD /
/
| #define HAVE_TEMPLATES //
| #define STDCXX_98_HEADERS /
/
| #define HAVE_STDCXX_0X //
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_XOPEN_SOURCE 420
| #define DEBUG 1
| #define STDC_HEADERS 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_STDBOOL_H 1
| #define size_t unsigned int
| #define ssize_t int
| #define off_t long int
| #define pid_t int
| #define HAVE_BOOL /
/
| /
end confdefs.h. */
| #ifdef STDC
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:9191: error: in /Users/clausklein/Downloads/agentpp/agent++-4.5.0/build': configure:9193: error: C++ preprocessor "/lib/cpp" fails sanity check See config.log’ for more details

bash-3.2$ which cpp

/usr/bin/cpp

bash-3.2$ ls /lib

ls: /lib: No such file or directory

bash-3.2$

bash-3.2$ autoreconf -i --force

glibtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, ‘build-aux’.

glibtoolize: copying file 'build-aux/ltmain.sh’

glibtoolize: putting macros in AC_CONFIG_MACRO_DIRS, ‘m4’.

glibtoolize: copying file 'm4/libtool.m4’

glibtoolize: copying file 'm4/ltoptions.m4’

glibtoolize: copying file 'm4/ltsugar.m4’

glibtoolize: copying file 'm4/ltversion.m4’

glibtoolize: copying file 'm4/lt~obsolete.m4’

configure.ac:69: warning: The macro `AC_LANG_CPLUSPLUS’ is obsolete.

configure.ac:69: You should run autoupdate.

./lib/autoconf/c.m4:262: AC_LANG_CPLUSPLUS is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_namespaces.m4:27: AX_CXX_NAMESPACES is expanded from…

configure.ac:69: the top level

configure.ac:69: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:69: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_namespaces.m4:27: AX_CXX_NAMESPACES is expanded from…

configure.ac:69: the top level

configure.ac:70: warning: The macro `AC_LANG_CPLUSPLUS’ is obsolete.

configure.ac:70: You should run autoupdate.

./lib/autoconf/c.m4:262: AC_LANG_CPLUSPLUS is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_namespace_std.m4:26: AX_CXX_NAMESPACE_STD is expanded from…

configure.ac:70: the top level

configure.ac:70: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:70: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_namespace_std.m4:26: AX_CXX_NAMESPACE_STD is expanded from…

configure.ac:70: the top level

configure.ac:71: warning: The macro `AC_LANG_CPLUSPLUS’ is obsolete.

configure.ac:71: You should run autoupdate.

./lib/autoconf/c.m4:262: AC_LANG_CPLUSPLUS is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_have_stl.m4:26: AX_CXX_HAVE_STL is expanded from…

configure.ac:71: the top level

configure.ac:71: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:71: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_have_stl.m4:26: AX_CXX_HAVE_STL is expanded from…

configure.ac:71: the top level

configure.ac:72: warning: The macro `AC_LANG_CPLUSPLUS’ is obsolete.

configure.ac:72: You should run autoupdate.

./lib/autoconf/c.m4:262: AC_LANG_CPLUSPLUS is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_have_std.m4:27: AX_CXX_HAVE_STD is expanded from…

configure.ac:72: the top level

configure.ac:72: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:72: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_have_std.m4:27: AX_CXX_HAVE_STD is expanded from…

configure.ac:72: the top level

configure.ac:73: warning: The macro `AC_LANG_CPLUSPLUS’ is obsolete.

configure.ac:73: You should run autoupdate.

./lib/autoconf/c.m4:262: AC_LANG_CPLUSPLUS is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_templates.m4:26: AX_CXX_TEMPLATES is expanded from…

configure.ac:73: the top level

configure.ac:73: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:73: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_templates.m4:26: AX_CXX_TEMPLATES is expanded from…

configure.ac:73: the top level

configure.ac:74: warning: The macro `AC_LANG_CPLUSPLUS’ is obsolete.

configure.ac:74: You should run autoupdate.

./lib/autoconf/c.m4:262: AC_LANG_CPLUSPLUS is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_header_stdcxx_98.m4:25: AX_CXX_HEADER_STDCXX_98 is expanded from…

configure.ac:74: the top level

configure.ac:74: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:74: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_header_stdcxx_98.m4:25: AX_CXX_HEADER_STDCXX_98 is expanded from…

configure.ac:74: the top level

configure.ac:75: warning: The macro `AC_LANG_CPLUSPLUS’ is obsolete.

configure.ac:75: You should run autoupdate.

./lib/autoconf/c.m4:262: AC_LANG_CPLUSPLUS is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_header_stdcxx_tr1.m4:25: AX_CXX_HEADER_STDCXX_TR1 is expanded from…

configure.ac:75: the top level

configure.ac:75: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:75: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_header_stdcxx_tr1.m4:25: AX_CXX_HEADER_STDCXX_TR1 is expanded from…

configure.ac:75: the top level

configure.ac:77: warning: The macro `AC_CXX_COMPILE_STDCXX_0X’ is obsolete.

configure.ac:77: You should run autoupdate.

m4/ax_cxx_compile_stdcxx_0x.m4:25: AC_CXX_COMPILE_STDCXX_0X is expanded from…

configure.ac:77: the top level

configure.ac:77: warning: The macro `AC_LANG_CPLUSPLUS’ is obsolete.

configure.ac:77: You should run autoupdate.

./lib/autoconf/c.m4:262: AC_LANG_CPLUSPLUS is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/ax_cxx_compile_stdcxx_0x.m4:26: AX_CXX_COMPILE_STDCXX_0X is expanded from…

m4/ax_cxx_compile_stdcxx_0x.m4:25: AC_CXX_COMPILE_STDCXX_0X is expanded from…

configure.ac:77: the top level

configure.ac:77: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:77: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/ax_cxx_compile_stdcxx_0x.m4:26: AX_CXX_COMPILE_STDCXX_0X is expanded from…

m4/ax_cxx_compile_stdcxx_0x.m4:25: AC_CXX_COMPILE_STDCXX_0X is expanded from…

configure.ac:77: the top level

configure.ac:78: warning: The macro `AC_LANG_CPLUSPLUS’ is obsolete.

configure.ac:78: You should run autoupdate.

./lib/autoconf/c.m4:262: AC_LANG_CPLUSPLUS is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/ax_compile_stdcxx_0x.m4:15: AC_COMPILE_STDCXX_0X is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_header_stdcxx_0x.m4:25: AX_CXX_HEADER_STDCXX_0X is expanded from…

configure.ac:78: the top level

configure.ac:78: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:78: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/ax_compile_stdcxx_0x.m4:15: AC_COMPILE_STDCXX_0X is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_header_stdcxx_0x.m4:25: AX_CXX_HEADER_STDCXX_0X is expanded from…

configure.ac:78: the top level

configure.ac:78: warning: The macro `AC_LANG_CPLUSPLUS’ is obsolete.

configure.ac:78: You should run autoupdate.

./lib/autoconf/c.m4:262: AC_LANG_CPLUSPLUS is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_header_stdcxx_0x.m4:25: AX_CXX_HEADER_STDCXX_0X is expanded from…

configure.ac:78: the top level

configure.ac:78: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:78: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_header_stdcxx_0x.m4:25: AX_CXX_HEADER_STDCXX_0X is expanded from…

configure.ac:78: the top level

configure.ac:97: warning: The macro `AC_HEADER_STDC’ is obsolete.

configure.ac:97: You should run autoupdate.

./lib/autoconf/headers.m4:704: AC_HEADER_STDC is expanded from…

m4/acx_xopen.m4:34: ACX_CHECK_XOPEN_SOURCE is expanded from…

configure.ac:97: the top level

configure.ac:97: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:97: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

m4/acx_xopen.m4:12: ACX_TRY_COMPILE_XOPEN_SOURCE is expanded from…

m4/acx_xopen.m4:34: ACX_CHECK_XOPEN_SOURCE is expanded from…

configure.ac:97: the top level

configure.ac:154: warning: The macro `AC_LANG_C’ is obsolete.

configure.ac:154: You should run autoupdate.

./lib/autoconf/c.m4:72: AC_LANG_C is expanded from…

m4/acx_win32.m4:5: ACX_WIN32 is expanded from…

configure.ac:154: the top level

configure.ac:154: warning: The macro `AC_LANG_C’ is obsolete.

configure.ac:154: You should run autoupdate.

./lib/autoconf/c.m4:72: AC_LANG_C is expanded from…

m4/acx_pthread.m4:50: ACX_PTHREAD is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

m4/acx_win32.m4:5: ACX_WIN32 is expanded from…

configure.ac:154: the top level

configure.ac:154: warning: The macro `AC_TRY_LINK’ is obsolete.

configure.ac:154: You should run autoupdate.

./lib/autoconf/general.m4:2920: AC_TRY_LINK is expanded from…

m4/acx_pthread.m4:50: ACX_PTHREAD is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

m4/acx_win32.m4:5: ACX_WIN32 is expanded from…

configure.ac:154: the top level

configure.ac:221: warning: The macro `AC_HEADER_STDC’ is obsolete.

configure.ac:221: You should run autoupdate.

./lib/autoconf/headers.m4:704: AC_HEADER_STDC is expanded from…

configure.ac:221: the top level

configure.ac:224: warning: The macro `AC_LANG_C’ is obsolete.

configure.ac:224: You should run autoupdate.

./lib/autoconf/c.m4:72: AC_LANG_C is expanded from…

m4/acx_win32.m4:5: ACX_WIN32 is expanded from…

configure.ac:224: the top level

configure.ac:247: warning: The macro `AC_LANG_CPLUSPLUS’ is obsolete.

configure.ac:247: You should run autoupdate.

./lib/autoconf/c.m4:262: AC_LANG_CPLUSPLUS is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_bool.m4:14: AC_CXX_BOOL is expanded from…

configure.ac:247: the top level

configure.ac:247: warning: The macro `AC_TRY_COMPILE’ is obsolete.

configure.ac:247: You should run autoupdate.

./lib/autoconf/general.m4:2847: AC_TRY_COMPILE is expanded from…

lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from…

lib/m4sugar/m4sh.m4:699: AS_IF is expanded from…

./lib/autoconf/general.m4:2249: AC_CACHE_VAL is expanded from…

./lib/autoconf/general.m4:2270: AC_CACHE_CHECK is expanded from…

m4/acx_cxx_bool.m4:14: AC_CXX_BOOL is expanded from…

configure.ac:247: the top level

configure.ac:652: warning: The macro `AC_PROG_LIBTOOL’ is obsolete.

configure.ac:652: You should run autoupdate.

m4/libtool.m4:99: AC_PROG_LIBTOOL is expanded from…

configure.ac:652: the top level

configure.ac:741: warning: AC_OUTPUT should be used without arguments.

configure.ac:741: You should run autoupdate.

configure.ac:57: installing 'build-aux/compile’

configure.ac:31: installing 'build-aux/missing’

agenpro/agent/src/Makefile.am: installing 'build-aux/depcomp’

bash-3.2$ autoupdate

configure.ac:221: warning: The preprocessor macro `STDC_HEADERS’ is obsolete.

Except in unusual embedded environments, you can safely include all

ISO C90 headers unconditionally.

bash-3.2$ cd build

bash-3.2$ …/configure

checking for a BSD-compatible install… /usr/local/bin/ginstall -c

checking whether build environment is sane… yes

checking for a race-free mkdir -p… /usr/local/bin/gmkdir -p

checking for gawk… no

checking for mawk… no

checking for nawk… no

checking for awk… awk

checking whether make sets $(MAKE)… yes

checking whether make supports nested variables… yes

checking whether to enable maintainer-specific portions of Makefiles… no

checking build system type… x86_64-apple-darwin20.3.0

checking host system type… x86_64-apple-darwin20.3.0

checking for gcc… gcc

checking whether the C compiler works… yes

checking for C compiler default output file name… a.out

checking for suffix of executables…

checking whether we are cross compiling… no

checking for suffix of object files… o

checking whether the compiler supports GNU C… yes

checking whether gcc accepts -g… yes

checking for gcc option to enable C11 features… none needed

checking whether gcc understands -c and -o together… yes

checking whether make supports the include directive… yes (GNU style)

checking dependency style of gcc… gcc3

checking for g++… g++

checking whether the compiler supports GNU C++… yes

checking whether g++ accepts -g… yes

checking for g++ option to enable C++11 features… none needed

checking dependency style of g++… gcc3

checking for gawk… (cached) awk

checking for grep that handles long lines and -e… /usr/bin/grep

checking how to run the C preprocessor… gcc -E

checking whether ln -s works… yes

checking whether make sets $(MAKE)… (cached) yes

checking for a sed that does not truncate output… /usr/bin/sed

checking for ar… ar

checking the archiver (ar) interface… ar

checking for pkg-config… /usr/local/bin/pkg-config

checking pkg-config is at least version 0.9.0… yes

checking whether the compiler implements namespaces… yes

checking if g++ supports namespace std… yes

checking whether the compiler supports Standard Template Library… yes

checking whether the compiler supports ISO C++ standard library… yes

checking whether the compiler supports basic templates… yes

checking for ISO C++ 98 include files… yes

checking for ISO C++ TR1 include files… no

checking if g++ supports C++0x features without additional flags… no

checking if g++ supports C++0x features with -std=c++0x… yes

checking if g++ supports C++0x features with -std=gnu++0x… yes

checking if g++ supports C++0x features without additional flags… no

checking if g++ supports C++0x features with -std=c++0x… no

checking if g++ supports C++0x features with -std=gnu++0x… no

checking for ISO C++ 0x include files… no

checking for gcc options needed to detect all undeclared functions… none needed

checking for stdio.h… yes

checking for stdlib.h… yes

checking for string.h… yes

checking for inttypes.h… yes

checking for stdint.h… yes

checking for strings.h… yes

checking for sys/stat.h… yes

checking for sys/types.h… yes

checking for unistd.h… yes

checking whether _AIX is declared… no

checking whether __linux is declared… no

…/configure: line 7524: syntax error near unexpected token `ac_fn_check_decl’

…/configure: line 7524: `fi ac_fn_check_decl “$LINENO” “__sun” “ac_cv_have_decl___sun” “$ac_includes_default” “$ac_c_undeclared_builtin_options” “CFLAGS”'

bash-3.2$

I do not get these warnings and errors, maybe your installation of autoconf is somehow broken or too old/new. I am using autoconf v2.69.

Normally, I do not use autoconf, just for test in this case. I always use or port to cmake.

And I do not use old tools.

bash-3.2$ brew info autoconf

autoconf: stable 2.71 (bottled)

Automatic configure script builder

https://www.gnu.org/software/autoconf

**/usr/local/Cellar/autoconf/2.71 (71 files, 3.2MB) ***

Poured from bottle on 2021-04-10 at 13:39:40

From: https://github.com/Homebrew/homebrew-core/blob/HEAD/Formula/autoconf.rb

License: GPL-3.0-or-later and (GPL-3.0-or-later with Autoconf-exception-3.0)

==> Dependencies

Required: m4 :heavy_check_mark:

==> Analytics

install: 246,030 (30 days), 580,148 (90 days), 1,446,430 (365 days)

install-on-request: 51,619 (30 days), 119,159 (90 days), 280,568 (365 days)

build-error: 0 (30 days)

bash-3.2$