Not able to poll CPU and MEMORY metrics from an ASA device

Hi All ,

i am not able to poll MEMORY and CPU metric from an ASA device .

Environment :
java8 application invokes snmp4j.jar code to perform an SNMP walk , same code is working for other devices but ASA device not able to poll CPU & MEMORY Metric .

Pls suggest …

We cannot help with this kind of questions. We do not know.

  1. the device,
  2. the query you send, and
  3. not what you expect to be returned.

One would need all of the above information to help.

Sorry. Please find my inline answers below

  1. the device,
    Ans: Cisco ASA (Adaptive Security Appliance) device
  2. the query you send, and
    Ans: SNMP_WALK for cpmCPUTotalIndex, cpmCPUTotalPhysicalIndex, cpmCPUTotal5sec, cpmCPUTotal5minRev with
    with oidList: [,,,]
  3. not what you expect to be returned.
    Ans: We are expecting responses for each OID type, something like:
    But, we are not receiving any response from ASA device and finally SNMP Timeout is generated. But the same java application code is working for other devices. Kindly help.

If you are not getting any response, the please check your security credentials used.
If they are correct, then the device is buggy.
A correct device would at least return a noSuchObject or noSuchInstance exception VB on a GET request.

Code is returning SNMP Timeout, but if I execute “snmpwalk” command to same device, device is returning proper response for CPU and Memory metrics.
Currently we are using snmp4j-2.5.0.jar. I have also tried with snmp4j-2.8.7.jar, but same result of SNMP timeout is observed.
Please let me know if this is the issue with snmp4j jar, as snmpwalk cmd is returning proper response.

Thanks for the quick response .

Same ASA device giving response to other metrics like ENTITY and INTERFACE only problem is with CPU and MEMORY metrics.

please help to provide reference to similar kind of issue if any .

any device level configuration modification can lead this kind of issue in case of cpu and memory metric ?


Maybe you have to increase the timeout value? Are you sure that snmpwalk and your SNMP4J code are sending the same SNMP PDU?

Thank you ,issue resolved .